周玨 / 通達信 / 通達信杰出智能買賣系統成套公式破解原碼

0 0

   

通達信杰出智能買賣系統成套公式破解原碼

2009-02-15  周玨
通達信杰出智能買賣系統成套公式破解原碼
2008年12月30日 星期二 20:19
通達信杰出智能買賣系統成套公式破解原碼:
首先要感謝原作者提供這么好的公式原碼,真誠的說一聲謝謝!
杰出智能系統,將葛南維法則完全程序化,盤中及時提示主力介入杰出智能系統,將葛南維法則完全程序化,盤中及時提示主力介入、頂部賣出、回調買入、抄底、反彈賣出,熊市降低套牢風險,牛市最大化波段收益!



葛南維八大法則
  
  在移動平均線中,美國投資專家葛南維(jogepsb ganvle)創造的八項法則可謂其中的精華,歷來的平均線使用者無不視其為技術分析中的至寶,而移動平均線也因為它,淋漓盡致地發揮了道·瓊斯理論的精神所在。 八大法則中的四條是用來研判買進時機,四條是研判賣出時機。總的來說,移動平均線在股價之下,而且又呈上升趨勢時是買進時機,反之,平均線在股價線之上,又呈下降趨勢時則是賣出時機。
  
  首先看買進時機。
  
  買1,平均線經過一路下滑后,逐漸轉為平滑,并有抬頭向上的跡象。別外,股價線也轉而上升,并自下方突破了移動平均線,這是第一個買進訊號。
  
  買2,股介線開始仍在移動平均線之上,但呈急劇下跌趨勢,在跌破移動平均線后,忽而轉頭向上,并自下方突破了移動平均線,這是第二個買進訊號。
  
  買3,與買2類似,但股價線尚未跌破移動平均線,只要移動平均線依然呈上升趨勢,前者也轉跌為升,這是第三個買進訊號。
  
  買4,股價線與移動平均線都在下降,問題在于股價線狠狠下挫,遠離了移動平均線,表明反彈指日可待,這第4個買進訊號甚為許多短線客喜愛(所謂搶谷底),但切忌不可戀戰,因為大勢依然不妙,久戰勢必套牢。
葛南維的四條賣出法則,與買進的四條法則是一一對應的。
  
  賣1,移動平均線從上升轉為平緩,并有轉下趨勢,而股價線也從其上方下落,跌破了移動平均線,這是第一個賣出訊號。
  
  賣2,股價線和移動平均線均很令人失望地下滑,這時股價線自下方上升,并突破了仍在下落的移動平均線后,又掉頭下落,這是第二個賣出訊號。
  
  賣3類似賣2,問題是稍現反彈的股價線更加軟弱,剛想突破移動平均線卻無力突破,這是第三個賣出訊號。要注意的是賣3與買1不同,買1是移動平均線自跌轉平,并有升跡象,而賣3,平均線尚處下滑之中。
  
  賣4,則股價一路暴漲,遠遠超過了雖也在上升的移動平均線,暴漲之后必有暴跌,所以此處是第四個賣出訊號,以防止暴跌帶來的不必要的損失。   經過長期應用后,我們發現,平均線轉跌為平,并有向上趨勢,股價從平均線下方突破平均線,并始終大致保持在移動平均線之上方,這一段是牛市;而反之,平均線轉升為平,并隨后下跌,股價線從平均線上方突破平均線之下方,這一段便是熊市了。
  至于買4和賣4,怎樣才算遠離移動平均線,何時為適度,這就是乖離率的研究對象了。

智能買賣系統用法:
下午2:30分后建議打開預警系統!
1.指數短趨勢上升階段可全倉操作,指數短趨勢下降階段半倉操作!
2.個股短趨勢上升階段可全倉操作(指數也是上升階段,否則半倉為宜);個股短趨勢下降階段半倉操作;
3.杰出智能系統中買指令含義:抄底-階段性底部,可適當買入(風險較小);反彈-下跌途中的反彈,適宜短線博反彈(風險較大);買入-上升途中的洗盤回調,可全倉買入(風險很小);
4.杰出智能系統中賣指令含義:減倉-上升遇到一定阻力,宜減少倉位,若成交量減小,則有可能是上升途中的洗盤;賣出-上升遇到強阻力,宜清倉;危險-指高位盤旋后即將下跌信號,宜清倉,放量-一般建議清倉觀望;
5.主力介入:指主力介入的信號,量能急劇放大,可考慮立即追漲,也可考慮回調后買入,須防止主力拉高出貨(注:主力包括機構、大戶、私募等);能買賣系統用法:





杰出智能買賣系統

{請一定要學習葛南維法則的精髓,才能夠合理使用該指標,通達信適用}
短趨勢線:MA(CLOSE,13),COLORRED,LINETHICK3;
中線:=MA(CLOSE,33),LINETHICK1;
中趨勢線:MA(CLOSE,55),LINETHICK1,COLORGRAY;
年線:MA(CLOSE,250),LINETHICK1,COLORLIGRAY,POINTDOT;

漲:IF(短趨勢線>REF(短趨勢線,1),短趨勢線,DRAWNULL),COLORRED,LINETHICK3;
平:=IF(短趨勢線=REF(短趨勢線,1),短趨勢線,DRAWNULL),COLOR00FFFF,LINETHICK3;
跌:IF(短趨勢線<REF(短趨勢線,1),短趨勢線,DRAWNULL),COLORGREEN,LINETHICK3;

上極限:=((C-REF(MA(CLOSE,20),1))/20+短趨勢線)*1.20;
DRAWTEXT(CROSS(CLOSE,上極限),H*1.02,'減倉'),COLORGREEN;
DRAWTEXT(CROSS(CLOSE,MA(C,13)) AND 短趨勢線<REF(短趨勢線 ,1) AND 短趨勢線<中趨勢線 ,H*1.02,'減倉'),COLORGREEN;

DRAWTEXT(CROSS(短趨勢線,C) AND INDEXC>MA(INDEXC,13) AND 短趨勢線>REF(短趨勢線 ,1) AND V<REF(V,1) AND 短趨勢線>中趨勢線 ,L*0.97,'買入'),COLORRED;
STICKLINE(CROSS(短趨勢線,C) AND 短趨勢線>REF(短趨勢線 ,1) AND V<REF(V,1) AND 短趨勢線>中趨勢線 ,L,L*0.99,2,0),COLORYELLOW;

VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
DRAWTEXT(VAR1>9 AND V<REF(V,1) AND FILTER(VAR1<REF(VAR1,1),5),H*1.02,'洗盤'),COLORYELLOW;
DRAWTEXT(VAR1>9 AND V>REF(V,1) AND FILTER(VAR1<REF(VAR1,1),5),H*1.02,'減倉'),COLORGREEN;
DRAWTEXT(VAR1>20 AND FILTER(VAR1<REF(VAR1,1),5),H*1.06,'賣出'),COLORYELLOW;

VAR2:=HHV(VAR1>20,10);
DRAWTEXT(FILTER(VAR1<-9 AND VAR1>REF(VAR1,1),18) AND V>REF(V,1),L*0.98,'反彈'),COLORRED;
DRAWTEXT(VAR1<-20 AND FILTER(VAR1> REF(VAR1,1),5),L*0.95,'抄底'),COLORYELLOW;
DRAWTEXT(VAR2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),H*1.1,'危險'),COLORYELLOW;


VAR12:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR12) * VOL);
VAR7:=((VAR4 / VAR12) * VOL);
VAR8:=((VAR5 / VAR12) * VOL);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
DRAWTEXT((((((VAR6 > (MA(VOL,5) * 2)) AND 短趨勢線>REF(短趨勢線 ,1) AND (VAR6 >= VAR7)) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARB)) ,L*0.98,'主力介入'),COLORMAGENTA;

年線:=MA(C,250);
漲幅:=C/O>1.09;
DRAWTEXT(漲幅 AND FILTER(漲幅>REF(漲幅,1),10),REF(年線,20),'杰出智能系統指標用法注釋有詳細的使用說明'),COLORYELLOW;

DDX:

虛擬量:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW,COLOR669900;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,虛擬量,0,3,-1),COLOR00C0C0;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交:VOL,POINTDOT;
主動買盤:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
主動賣盤:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),COLOR00FF00,POINTDOT;
STICKLINE(VOL>0,VOL,0,3,1),COLORWHITE;
STICKLINE(主動買盤>0,0,主動買盤,3,0),COLORRED;
DDX:主動買盤+主動賣盤,COLORYELLOW;


下面是五個選股公式,也就是預警里面要用到的公式:
回調買入:

VAR1:CROSS(MA(C,13),C) AND MA(C,13)>REF(MA(C,13) ,1) AND INDEXC>MA(INDEXC,13) AND MA(C,13)>MA(C,55) AND V<REF(V,1);

反彈賣出:

短趨勢線:=MA(C,13);
中趨勢線:=MA(C,55);

FANTAN:CROSS(CLOSE,MA(C,13)) AND 短趨勢線<REF(短趨勢線 ,1) AND 短趨勢線<中趨勢線;


頂部賣出:
VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
MAICHU:VAR1>20 AND FILTER(VAR1<REF(VAR1,1),5);


底部買入:
VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
MAIRU:VAR1<-20 AND INDEXC<MA(INDEXC,13) AND FILTER(VAR1> REF(VAR1,1),5);


主力介入:
VAR12:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR12) * VOL);
VAR7:=((VAR4 / VAR12) * VOL);
VAR8:=((VAR5 / VAR12) * VOL);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
短趨勢線:=MA(C,13);
ZHULI:(((((VAR6 > (MA(VOL,5) * 2)) AND 短趨勢線>REF(短趨勢線 ,1) AND (VAR6 >= VAR7)) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARB AND 短趨勢線>REF(短趨勢線 ,1)));

    本站是提供個人知識管理的網絡存儲空間,所有內容均由用戶發布,不代表本站觀點。如發現有害或侵權內容,請點擊這里 或 撥打24小時舉報電話:4000070609 與我們聯系。

    猜你喜歡

    0條評論

    發表

    請遵守用戶 評論公約

    類似文章
    喜歡該文的人也喜歡 更多

    betway <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <文本链> <文本链> <文本链> <文本链> <文本链> <文本链>